user-mode linux (uml) · Maintained
Maintainers
- M Richard Weinberger <richard@nod.at>
- M Anton Ivanov <anton.ivanov@cambridgegreys.com>
- M Johannes Berg <johannes@sipsolutions.net>
Paths
- F
Documentation/virt/uml/ - F
arch/um/ - F
arch/x86/um/ - F
fs/hostfs/
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-ext4 (capped at 30), ordered by date desc.
-
STALE127d
[PATCH 44/53] hostfs: don't d_drop() before d_splice_alias() in hostfs_mkdir()
2026-03-12 · NeilBrown <hidden> -
STALE241d
REVIEWED: 2 (2M) [PATCH RESEND v3] vfs: remove the excl argument from the ->create() inode_operation
2025-12-01 · Jeff Layton <jlayton@kernel.org> -
DORMANTno replies
REVIEWED: 2 (2M) [PATCH v3] vfs: remove the excl argument from the ->create() inode_operation
2025-11-10 · Jeff Layton <jlayton@kernel.org> -
STALE264d
[PATCH v2] vfs: remove the excl argument from the ->create() inode_operation
2025-11-07 · Jeff Layton <jlayton@kernel.org> -
STALE267d
[PATCH] vfs: remove the excl argument from the ->create() inode_operation
2025-11-05 · Jeff Layton <jlayton@kernel.org> -
STALE286d
[PATCH v2 16/27 5.10.y] minmax: make generic MIN() and MAX() macros available everywhere
2025-10-17 · Eliav Farber <hidden> -
STALE285d
[PATCH v7 04/14] Coccinelle-based conversion to use ->i_state accessors
2025-10-09 · Mateusz Guzik <hidden> -
STALE288d
[PATCH v3 08/19 5.15.y] minmax: make generic MIN() and MAX() macros available everywhere
2025-10-08 · Eliav Farber <hidden> -
STALE297d
[PATCH v2 08/19 5.15.y] minmax: make generic MIN() and MAX() macros available everywhere
2025-10-03 · Eliav Farber <hidden> -
STALE302d
[PATCH 06/19 5.15.y] minmax: make generic MIN() and MAX() macros available everywhere
2025-10-02 · Eliav Farber <hidden> -
STALE305d
[PATCH 07/19 v6.1.y] minmax: make generic MIN() and MAX() macros available everywhere
2025-09-24 · Eliav Farber <hidden> -
STALE298d
[PATCH v6 2/4] Convert the kernel to use ->i_state accessors
2025-09-23 · Mateusz Guzik <hidden> -
STALE313d
[PATCH v5 2/4] Convert the kernel to use ->i_state accessors
2025-09-19 · Mateusz Guzik <hidden> -
STALE313d
[PATCH 15/27 5.10.y] minmax: make generic MIN() and MAX() macros available everywhere
2025-09-19 · Eliav Farber <hidden> -
STALE316d
[PATCH v4 03/12] fs: mechanically convert most filesystems to use ->i_state accessors
2025-09-16 · Mateusz Guzik <hidden> -
STALE295d
[PATCH RESEND 55/62] init: rename CONFIG_BLK_DEV_INITRD to CONFIG_INITRAMFS
2025-09-14 · Askar Safin <hidden> -
STALE295d
[PATCH RESEND 42/62] init: rename <linux/initrd.h> to <linux/initramfs.h>
2025-09-14 · Askar Safin <hidden> -
STALE295d
[PATCH RESEND 28/62] init: alpha, arc, arm, arm64, csky, m68k, microblaze, mips, nios2, openrisc, parisc, powerpc, s390, sh, sparc, um, x86, xtensa: rename initrd_{start,end} to virt_external_initramfs_{start,end}
2025-09-13 · Askar Safin <hidden> -
STALE320d
[PATCH v3 3/4] convert all filesystems to use the new ->i_state accessors
2025-09-11 · Mateusz Guzik <hidden> -
STALE380d
LANDED [PATCH v6 3/5] fs: change write_begin/write_end interface to take struct kiocb *
2025-07-16 · 陈涛涛 Taotao Chen <hidden> -
STALE381d
[PATCH v5 3/5] fs: change write_begin/write_end interface to take struct kiocb *
2025-07-10 · 陈涛涛 Taotao Chen <hidden> -
STALE389d
[PATCH v4 3/5] fs: change write_begin/write_end interface to take struct kiocb *
2025-07-07 · 陈涛涛 Taotao Chen <hidden> -
STALE394d
[PATCH v3 3/4] fs: change write_begin/write_end interface to take struct kiocb *
2025-06-27 · 陈涛涛 Taotao Chen <hidden> -
STALE400d
[PATCH v2 3/5] fs: change write_begin/write_end interface to take struct kiocb *
2025-06-24 · 陈涛涛 Taotao Chen <hidden> -
STALE364d
LANDED [PATCH 08/10] fs: convert simple use of generic_file_*_mmap() to .mmap_prepare()
2025-06-16 · Lorenzo Stoakes <hidden> -
STALE1275d
[PATCH v2 3/6] mm: replace vma->vm_flags direct modifications with modifier calls
2023-01-25 · Suren Baghdasaryan <surenb@google.com> -
STALE1565d
LANDED: 2 (2M) [PATCH 24/27] block: remove QUEUE_FLAG_DISCARD
2022-04-15 · Christoph Hellwig <hch@lst.de> -
STALE1572d
REVIEWED: 2 (2M) [PATCH 24/27] block: remove QUEUE_FLAG_DISCARD
2022-04-09 · Christoph Hellwig <hch@lst.de> -
STALE1572d
[PATCH 25/27] block: remove QUEUE_FLAG_DISCARD
2022-04-06 · Christoph Hellwig <hch@lst.de> -
STALE1626d
[PATCH][next] treewide: Replace zero-length arrays with flexible-array members
2022-02-15 · "Gustavo A. R. Silva" <gustavoars@kernel.org>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE127d
[PATCH 44/53] hostfs: don't d_drop() before d_splice_alias() in hostfs_mkdir()
2026-03-12 · NeilBrown <hidden>